DelphiFAQ Home Search:

Credentials supplied conflict with an existing set of credentials

 

comments30 comments. Current rating: 5 stars (16 votes). Leave comments and/ or rate it.

Question:

This is not directly Delphi related but happens sometimes when setting up shared drives. In my case, I got this error message after installing SAMBA on a Linux box, then sharing a directory and the protecting this resource on the Linux side with an account.

I tried to access the shared resource from a Windows NT machine via Explorer or command line using NET USE - but kept getting this error message:
'Credentials supplied conflict with an existing set of credentials'

(On a Windows XP box this error did not occur.)

Answer:

From Microsoft: 'Windows NT does not allow you to make multiple connections to a shared network server from the same workstation if you attempt to use more than one set of credentials.'

This was basically a long winded version of the error message. Not too helpful. I looked at my shares but could not see any mapped drives to that machine except the IPC entry.

Solution:

At the command line, in a desperate attempt, I removed all shares to other machines with this trick:

NET USE * /DELETE

It was an attempt because until now I didn't realize that the NET command accepts wildcards (*) for machine names.

After that I could connect just fine. I suppose booting the machine would have done the trick as well.

Note:
Another possiblity is to provide the TCP/IP address of the computer instead of the computer name when you make that second connection. If you were already using the IP number in the first place, try the machine name this time. That might save you from removing all your network shares.


Comments:

You are on page 1 of 2, other pages: [1] 2
2006-01-06, 19:22:36
anonymous from United States  
rating
Thanks - solved my problem.
I wasted 3hrs trying to figure out what was wrong with my samba config, which was nothing.
2006-02-24, 18:52:50
pigdog007 from United States  
It worked for me too. I had a W2K box trying to join domain of NT server 4.0 and kept getting the message. After I deleted the mapped drive I could join the domain with no problems.

Thanks for the great tip!
2006-03-17, 10:52:25
anjanisairam@yahoo.com from India  
rating
Thanks alottt it solved my problem also.

thank you very much.
2006-04-04, 00:02:31
anonymous from India  
Thanks a lot.

My problem also got solved.But i didn't get why this is hapeening.Can anyone please explain
2006-04-04, 00:03:41
shridhark@cybage.com from India  
Thanks a lot.

My problem also got solved.But i didn't get why this is hapeening.Can anyone please explain
2006-05-06, 20:34:07
anonymous from United States  
Thanks for the help. This was what I needed.
2006-05-08, 02:27:36
anonymous from Sweden  
rating
Well, it happens because Microsoft prefers to leave broken code, that has been known to be broken for _years_, in windows over fixing it.
This is a bug. Plain and simple. Don't expect it too be fixed though. Most likely Microsoft considers it a feature that keeps you from getting confused by the mindbogglingly complex logic of being able to connect to different shares using different users.

And even if you accept that piece of ******* :
1. How do they explain that you do not get the choice to replace the credentials?
2. How do they explain that the connection does not turn up in net use?
3. How are you supposed to fix this without completely unreasonable amounts of effort when you have shares constantly being accessing by active processes?

/VeryTiredOfThisBugThatShouldHaveBeenFixedInWin95
2006-05-18, 04:45:55
anonymous from Philippines  
thanks you save my day configuring samba w/ window$ NT (neanderthal technology) ^-^ based machines
2006-05-20, 17:53:29
anonymous from United States  
Great tip, thanks!
2006-06-02, 00:40:42
getsalmanahmed@yahoo.com from Pakistan  
rating
Thanks a lot
2006-07-23, 07:54:38
anonymous from Iran  
Great Tip!
2006-08-21, 12:29:03
Thank You!!!! from United States  
rating
That is great....still not sure what you did....but it worked.....thanks.....
2006-09-19, 16:22:25
anonymous from Australia  
my next computer purchase will be apple so I don't have to use microsoft's ******* software
2006-10-12, 09:04:35
anonymous from United States  
rating
Great solution... worked for me too... I had this problem for some time...:-)
2006-11-03, 09:33:40
HS Teacher from United States  
rating
Thank you - This helped a lot :o)

Note to self: Remove all shares from the admin account when making images ;o)
You are on page 1 of 2, other pages: [1] 2

 

 

NEW: Optional: Register   Login
Email address (not necessary):

Rate as
Hide my email when showing my comment.
Please notify me once a day about new comments on this topic.
Please provide a valid email address if you select this option, or post under a registered account.
 

Show city and country
Show country only
Hide my location
You can mark text as 'quoted' by putting [quote] .. [/quote] around it.
Please type in the code:

Please do not post inappropriate pictures. Inappropriate pictures include pictures of minors and nudity.
The owner of this web site reserves the right to delete such material.

photo Add a picture: