DelphiFAQ Home Search:

The meaning of Runtime Error 217

 

comments87 comments. Current rating: 4 stars (18 votes). Leave comments and/ or rate it.

The online help that comes with Delphi lists "control-C-exit" as the reason for a runtime error 217, here a listing of Delphi 3 Runtime Errors:


 STATUS_FLOAT_DIVIDE_BY_ZERO:    200;
 STATUS_INTEGER_DIVIDE_BY_ZERO:  200;
 STATUS_ARRAY_BOUNDS_EXCEEDED:   201;
 STATUS_STACK_OVERFLOW:          202;
 STATUS_FLOAT_OVERFLOW:          205;
 STATUS_FLOAT_UNDERFLOW,
 STATUS_FLOAT_DENORMAL_OPERAND:  206;
 STATUS_FLOAT_INEXACT_RESULT,
 STATUS_FLOAT_INVALID_OPERATION,
 STATUS_FLOAT_STACK_CHECK:       207;
 STATUS_INTEGER_OVERFLOW:        215;
 STATUS_ACCESS_VIOLATION:        216;
 STATUS_CONTROL_C_EXIT:          217;
 STATUS_PRIVILEGED_INSTRUCTION:  218;
In the case of 217, this listing is wrong.

In fact, Delphi executables will die with runtime error 217 when an exception was raised before SysUtils is initialized or after it is finalized. In both situations the regular exception handling is not put in place.

If the error occurs right at your application's startup, check your initialization sections. Try to move code into a later part, e.g. into FormCreate() events.
Otherwise check your units' finalization sections.

Some typical situations where this can happen:

  • unexpected date formats
  • disk or registry accesses where the user has not sufficient privileges
  • BDE Net Dir mismatches



Content-type: text/html

Comments:

You are on page 2 of 6, other pages: 1 [2] 3 4 5 6
2006-11-03, 21:34:10
anonymous from India  
nice to get knowledge abt Run time errors
2006-11-05, 02:52:47
anonymous from United States  
It seems that I might finally have remedied the problem however I'm still not certain as to why it's occurring. I ran MSCONFIG in Windows XP and unchecked all of the references to ATI in both the Startup and Services tabs and now the problem is no longer occurring.
2006-11-08, 16:03:37
lukiv_mom@hotmail.com from Canada  
I am also getting the same error message everytime I close Internet Explorer. Please let me know how to solve this problem
2006-11-10, 10:04:28
anonymous from United States  
Do you have an ATI video card ?
2006-11-14, 20:14:19
anonymous from Canada  
rating
Yes - I do. I will try the previous suggestion to run MSCONFIG and let you know if that works.
2006-11-23, 11:48:02
anonymous from United States  
I am getting the same error message when I close IE7, but I have an nvidia video card. ??
2006-11-24, 09:48:50
anonymous from United States  
IE7 sux. But besides that, try running SFC /SCANNOW after disabling the Nvidia control panel softwares in MSCONFIG.
2006-11-25, 12:33:18
as4097303@sapo.pt from Portugal  
rating
Please, I need solution to 'runtime error 217 at 0481F2C2'. OS WinXp spk2 home edirion. Many Thanks.
José Grilo
2006-12-10, 04:47:44
[hidden] from Italy  
I keep getting the ''The exception unknown software exception (0x0eedfade) occured int he application at location 0x7c812a5b' pop-up! Goin' crazy! please, help!!!!
2006-12-11, 08:25:47
anonymous from United States  
Disable the ATI HotKey Poller, ATI Smart and Office Source Engine in the Services Tab of MSCONFIG.
2006-12-14, 10:14:32
anonymous from United Kingdom  
rating
Could anonymous please explain for a real dummy click by click how to disable the items he/she referred to (ATI Hot Key Poller etc). Then I too can get rid of my OxOeedfade bug! Thanks
2006-12-15, 11:27:17
anonymous from United States  
1) Click on 'Start' .
2) Click on 'Run' .
3) In the 'Open' box type 'MSCONFIG' without the quotes.
4) Click 'OK'.
5) Click on the tab that is labeled 'Services'.
6) Check the box that says 'Hide All Microsoft Services'
7) Uncheck the boxes for ATI Hotkey Poller, ATI Smart, any other ATI entries as we as 8) 8) Office Source Engine. Click on 'Apply'.
9) Click on 'OK'.
10) Click 'Restart' on the box that pops up.

Note that if the above steps do not resolve your issue, run through steps 1 ~ 4 and click on the tab labeled 'Startup'. Look for anything there that has the word 'ATI' in it and uncheck it as well. Note that this is a _Windows_ issue and not specific to the applications. This is just a work-around that has worked for me.

2006-12-17, 13:54:56
anonymous from United States  
Okay everybody has the same problem. So where is the freakin' (fu#$%^%%^%ing) solutiion? Is it a viral bug ? or something. It is sooooo annoying. Someone must have the answer so post it please !.
2006-12-17, 14:55:45
anonymous from United States  
trojan horse !
2006-12-18, 07:39:46
anonymous from United States  
Must be a bunch of illiterate Amerikans on this board. TTFN !
You are on page 2 of 6, other pages: 1 [2] 3 4 5 6

 

 

NEW: Optional: Register   Login
Email address (not necessary):

Rate as
Hide my email when showing my comment.
Please notify me once a day about new comments on this topic.
Please provide a valid email address if you select this option, or post under a registered account.
 

Show city and country
Show country only
Hide my location
You can mark text as 'quoted' by putting [quote] .. [/quote] around it.
Please type in the code:

Please do not post inappropriate pictures. Inappropriate pictures include pictures of minors and nudity.
The owner of this web site reserves the right to delete such material.

photo Add a picture: